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USING MOTION CAPTURE DATA IN YOUR STUDIOPRO MODE

Credo Interactive, Inc.’s Life Forms® now supports Strata’s new SHM (S
chical Motion) extension, making it possible to use both StudioPro and L
make animations easier. You can animate IK structures in Life Forms, the
into StudioPro and add geometry, textures, etc. This document explains h
new feature, and includes a tutorial.

The SHM import/export extension requires StudioPro v2.5.3 or later, and
junction with the IK feature in Strata’s Power Module 1.

Life Forms is a motion editing and design software (see Animating in Li
page 21). Life Forms now imports and exports the SHM file format. This 
allows you to bring motion capture and other pre-made keyframed sequ
Life Forms into Strata Studio Pro.

Life Forms can export any Life Forms animation file as a SHM file. When
mation is exported to a SHM file, the animation is represented by a bone
from the model’s geometry. Because the model’s geometry affects the bo
ated in the SHM file, you should carefully choose the model you use for 
motion data that for Strata Studio Pro.The geometry of the model is not e
present time.

TO EXPORT SHM FILES FROM LIFE FORMS
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Tip: Life Forms allows you to paste keyframes from one model to anothe
make use of this function to apply existing motion to simpler models bef
SHM files.

To export SHM files from Life Forms:

1. Choose File menu > Export

2. Select Strata SHM in the Format List

3. You will see the following options in the Export dialog box:

• Scale to Original size:

Check this option if you have scaled the SHM bone figure in Life Form
remembers the original size of the figure. Checking this option allows
scale the motion data back to its original size.

• Export one figure per file:

This option is selected by default. When this option is checked Life Fo
only one figure per file. This option must be checked if your animatio
more than one figure.
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Motion data in SHM files can go both ways: into and out of Life Forms. 

To import SHM files in Life Forms:

1. In Life Forms, choose File menu > Open.

2. In the File types menu select Strata SHM.

3. Browse and select the SHM file you want to open.

4. Click Open.

Open, Open As: Use the Open or Open As commands in the File menu t
SHM file in a new modeling window in StudioPro. This new model cont
hierarchy and its associated animation data only. It does not contain any
tures, etc., until you create or apply them.

Import: Use this command to import motion data into an existing Studio
When you import an SHM file, the software checks to see if there is alrea
ture of the same name. If not, the IK structure is imported along with the
If the IK structure is already present in the model, the new motion data r
(updates) its old animation data. Only the animation data is imported.

TO OPEN SHM FILES IN LIFE FORMS

TO OPEN SHM FILES IN STUDIOPRO
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This is a very powerful feature which allows you to work in StudioPro a
simultaneously. For example, perhaps you’ve created and animated an IK
Life Forms, exported it as an SHM file, brought it into StudioPro and add
Now you decide to tweak the motion of the IK slightly. You don’t have to
out of StudioPro and back into Life Forms. Instead, just work with the or
Life Forms, change the animation as desired, then use Life Form’s Expor
save the file as an SHM file. Now, use StudioPro’s Import command to im
into StudioPro. Only the animation information is imported to the asso
ture, replacing all of the previous animation data, but leaving all of the o
intact.

Save As: If you’ve altered the animation of the Life Forms model in Stud
use the Save As command to save the file as an SHM file. All IK and ani
are saved and can be opened in Life Forms. (Only IK and motion data ar
geometry, textures, etc.)

The SHM filename must contain the .shm suffix. (Macintosh users: If you
“Save with file type suffix” checkbox on the General tab of the Preferenc
dioPro will do this for you automatically.)

Then, once you’ve finished animating the IK structure and have exported
Forms as an SHM file, you can use the Import command in StudioPro to
the animation data back into your StudioPro model. This animation dat
assigned to the original IK structure.

TO EXPORT SHM FILES OUT OF STUDIOPRO
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Forms 3 Demo 
TUTORIAL

This tutorial will guide you through the process of creating and animatin
using StudioPro and a file imported from Credo Interactive’s Life Forms
advanced tutorial designed for people who are familiar with Strata Stud
StudioPro users should familiarize themselves with the basics of the app
trying this tutorial. For beginner tutorials, see StudioPro Basics in the Us

In the Life Forms 3 Demo folder > Strata folder you will find the Life Fo
will need, as well as models of this tutorial in various stages of completio
create your own model, or use the models provided.

Look for the Strata icon to identify the model that includes all 
the steps up to that point. 

The first step is to export motion data from Life Forms. For this tutorial, 
run to a SHM file called Run.shm. The following steps describe how to d
wish to skip this step you may do so. 

 Run.shm file stores animation exported from Life Forms. This file is in the Life 
folder> Strata folder.

1. Choose File menu > Browse. This opens the File Browser.

EXPORTING MOTION FROM LIFE FORMS
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2. In the File Browser, browse to the Animation Gallery folder/ Run
Run2.lfa.

3. To export the run animation, choose File menu > Export.

4. In the Export dialog box, select Strata SHM from the Export List. D
of the export options that appear. Click OK.

5. Name the file Run.shm and click OK.

1. Launch StudioPro and select New from the File menu to open a ne
dow.

2. Select Import from the File menu. Select the Run.shm file, located i
Demo folder/ Strata folder. 

3. Select Fit Views to All from the Windows menu. (The Life Forms I
open in meters, so it may appear extremely large.)

4. Choose Right from the View Orientation pop-up. This will give yo
of the IK structure.

IMPORT IK STRUCTURE AND ITS MOTION 
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1. Change the Display Method pop-up to PointCloud. The appearance o
ture won’t change much in this display mode, but the bones won’t be
the geometry as you create it.

2. Select the Sphere tool on the main Tool palette. Place 
the cursor on the center of one of the upper arms, then 
hold down the Option key (Macintosh) or Alt key 
(Windows) and drag outward to create an oblong 
shape that’s centered on the bone and is roughly the 
size of the upper arm bone.

 NOTE: Using the Option key (Macintosh) or the Alt key (Windows) 
draws the sphere from the center. This is the easiest way to center 
the sphere on the bone.

3. Select the Move tool, then Option-drag (Macintosh) or Alt-drag (Wind
sphere to the other upper arm segment. This creates an identical copy
quickest way to create matching limbs for a body.

4. Repeat steps 1 and 2 to add a sphere to each arm and leg bone. Use th
necessary, to adjust your view of the model.

CREATE A BODY

Click here...

...and drag out-
ward to here
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5. Use a large sphere for the torso, and a smaller sphere for the 
head. Fill in the neck and shoulder areas with small spheres.

6. Switch to the Top view to add spheres for the feet.

7. Switch back to the Right view when you’re through creating 
the body.

Your figure should look similar to this
when all of the spheres have been added.

Use the Metaball feature to smooth the figure’s geometry.

1. In the Project window, hide the IK -Actor 1 by clicking the Hide/Show
its name.

2. Change the Display method to Shaded.

3. Use the Select All command from the Edit menu to select all of the sp

METABALL

Click the “Eye” icon to toggle between 
HIDE and SHOW.
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4. Select the Metaballs command from the Modeling menu. All the sphe
together.

5. Play with the Influence slider on the left side of the Metaballs Object 
ette until you’re satisfied with the look of the figure.

NOTE: You can always use the UnMetaballs command, if necessary, 
otherwise manipulate the individual spheres. (You may want to make
that you created for the lower arms or torso narrower to prevent them
ling together.)

 The model titled Model1.smd includes all of the steps up to this point. It is loca
Forms 3 Demo folder> Strata folder on the Installer CD. 

SAVE THE MODEL, THEN CONVERT

Use the slider to adjust the influ-
ence between spheres.
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Now’s a good time to save the model, because once you convert it into a
mesh, you can’t convert it back to a Metaballs object again, and you won
further access to the spheres. 

1. Save the model. Then use the Save a Copy As command to save a ver
model that has not been converted to poly mesh.

2. Then, select the Convert command in the Modeling menu.

3. From the Convert dialog, select Polygon Mesh, then click OK.

1. Make sure the Display Method is set to PointCloud.

2. In the Project window, Show the hidden IK structure (IK-Actor 1) by 
Hide/Show icon.

3. Select the Attach tool on the main Tool palette. 

4. Hold down the Option key (Macintosh) or the Alt key (Windows), the
and drag to the poly mesh. When both the IK and the mesh highlight 
attachment is complete. Without the Option/Alt key, only a single bo
attached to the entire IK structure. 

HINT: If you’ve successfully attached the entire IK structure to the po
“Mesh” entry in the Project window changes to “IK Mesh”. If, instead

ATTACH THE POLY MESH
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dentally attached a single bone to the poly mesh, the “Mesh” entry is p
the “IK-Actor 1” entry, and no longer appears on the main level. If thi
can use the Undo command to undo the action, but only if you use it 
after attaching. If you can’t Undo, you must use the Detach tool to de
from the single bone, and try again. Be sure you depress the Option ke
or Alt key (Windows) BEFORE you select the IK structure with the A

You must make sure that each piece of the poly mesh is associated to the 
the IK structure. Otherwise, the geometry will tear as points try to move
wrong bone.

This procedure tends to be the most tedious part of process, so be patien
on the machine you’re using and the complexity of the IK structure, this 
substantial amount of time to redraw the screen between tasks. 

1. Select the IK-Actor 1. Use the Control key (Macintosh) or the 
right mouse button (Windows), if necessary, to prevent select-
ing the IK Mesh instead; or, select the IK-Actor 1 in the Project 
window.

2. Select the Reshape command in the Model-
ing menu, or click the Reshape button on the 
Button bar.

FINE-TUNE PROCEDURES
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3. Select the Vertex tool  from the Reshape tool palette. With this tool 
points of geometry associated with the bone selected in the Object Prope
appear RED. Points associated with other bones appear GREEN. Points
ated with ANY bone appear BLUE. 

4. Hold down the Command key (Macintosh) or the Ctrl key (Windows), 
Vertex tool to select all points, and the geometry they control, that you w
ated with the selected bone. This modifier key ensures that all points on
axis are selected, as well. Without this key, you may miss some of the ver
the back. 

You won’t need to change any of the rotatio
This information is part of the SHM file imp
Forms.

When you select a bone 
in this list...

...associated points     
 appear red.

The number of points not associ-
ated with ANY bone appear in 
the Stray Points field. (These 
points appear blue.)
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5. On the Object Properties palette, change the Flex slider to 
zero to prevent the geometry from bulging as the figure is 
animated.

6. Select each bone in the list to make sure that the appropriate points a
with it. Also, check the Flex setting for each bone and make sure its se

7. If there are points that aren’t associated with ANY bone (stray points)
will appear BLUE. Be sure to check the Stray Point field (directly belo
list) to see if there are any unassociated points. If there are, you must lo
assign them to a bone. If you don’t, these unassociated points won’t m
figure when it’s animated. Instead, they’ll remain fixed in their presen

8. Select the End/Reshape Edit command from the Modeling menu to ex
mode.

The model titled Model2.smd includes all of the steps up to this
the vertex points in this model are assigned to the proper bones

Once you’ve finished assigning all the vertex points to bones, you’ll need
mesh to the IK structure, so when you animate the figure, the geometry m
bones. But first, select a texture and apply it to the mesh.

1. Select the IK Mesh in the Modeling window. 

APPLY A TEXTURE, AND LINK THE IK MESH TO THE BONES
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2. Select a texture from the Textures tab of the Resource palette, then clic
button to apply the texture to the mesh. (The texture on our model is M
It’s located in the Stone’s Throw™ folder.)

3. Select the Link tool. 

4. Select the mesh first, then drag to select the IK.

Both the mesh and the IK structure highlight to 
indicate the link is complete.

NOTE: Once properly linked, the IK Mesh entry 
no longer appears in the top level of the Project 
window. Instead, it disappears into a Link node 
inside the IK-Actor 1’s Object Properties. 

1. On the Ground tab of the Environment palette, check the Ground Pla
select a texture. (We used the “Old Copper” texture, located in the Dir
tion™ folder.)

NOTE: You may want to use a large flattened cube instead of a groun
reduce the amount of time required for rendering.

GET READY TO RENDER
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2. Select Top from the View Orientation pop-up.

3. Select the Camera tool, then insert a camera 
beside (below) the figure. You many need to 
zoom out to place the camera far enough 
from the figure to keep it in the camera’s view 
at all times.

4. With the Object Move tool, grab the Look At 
point and drag it CLOSE TO, but not ON, the figure.

- OR -

Grab the Look At point with the Object Move tool, then hold down th
(Macintosh) or the Alt key (Windows) and drag to the figure. The figu
in green to indicate that the camera is aimed at it, but not locked onto

5. Switch to the Front view, then grab the camera and raise it so it’s app
waist level on the figure.

6. Select Camera-1 from the Windows>Camera Windows pop-up to op
window. You can make any last minute adjustments in this window.

Top view

If the camer
isn’t visible,
camera slig
see the red 
where the c
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7. With the Option key (Macintosh) or the Alt key (Windows) depressed
Views to All from the Windows menu. Using the Option/Alt key also
animation path to fit in the view.

8. Move the Current Time pointer to the Cut-Out point.

Current Time Pointer
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9. With both the figure and the Camera 
selected, grab the line that runs 
between the camera and the cam-
era’s Look At point and drag to the 
end of the figure’s animation path. 
(If the figure is not also selected, you 
won’t be able to see it’s animation 
path, so it’s important that both are 
selected.)

NOTE: By grabbing the line 
between the camera and its Look At 
point, BOTH the camera AND the 
Look At point move together.

The model titled Model3.smd includes all of the steps up to this
thing is all set to begin the rendering.

 

1. Double-click on the camera icon in the Modeling window to open its 
dow, or select Camera-1 from the Windows>Camera Windows pop-u

2. Select the Render command from the Rendering menu.

RENDER THE ANIMATION

Grab this line 
and drag.
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3. Select Scanline-Good from the Renderer pop-up. 

4. Click the Expert button to display the 
Scanline Esoterica dialog.

5. Check the Shadows checkbox to enable 
shadows, then click OK to close the dia-
log.

6. In the Render dialog, click the All button 
to render all of the frames in the anima-
tion.

7. Click Render, then name the file and 
select a compression format from the 
dialogs that follow.

When all of the frames complete rendering, 
the animation opens in a playback window. 
Click the Play button to view the anima-
tion.

– OR –
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an.mov in the 
You can view our pre-rendered animation by opening the CredoStrataM
Life Forms 3 Demo folder>Strata folder on the Installer CD.
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ANIMATING IN LIFE FORMS 3

Life Forms has a simplified yet highly effective interface for animating se
acters and bones. This interface is ideal for creating keyframed animation
editing motion capture data. Seasoned 3D Artists that are getting into the
mation business as well as professional animators will find Life Forms u
quickly adding motion to their projects and for working with motion cap
sets. Here are a few reasons why we think so.

Life Forms is a specialist in Keyframing. When you want to create custom
from scratch, Life Forms is the tool to use. It has:

• a Figure Editor for fast and accurate positioning of joints;
• simple controls for adjusting location and facing angle of the figure in t
• graphical Timeline that gives you the ability navigate through the ani

expand or contract selected frames.

Life Forms allows you to explore, exercise, and expand your character an

A KEYFRAMER
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Life Forms Studio 3 comes with a library of models and motions called
This library contains 120 motion captured sequences, and over 600 other 
you can reuse as is, recombine, or modify. The non-Studio version of Life
not include the PowerMoves 1&II Library but still provides a starter set o
models.

Life Form’s Smart Paste functions make it unique. These functions save y
trouble by enabling you to:

• assemble a longer animation from short pre-made sequences. When y
animation in front of, after, or in the middle of another animation Life 
matically recalculates the location values to produce a continuous path

• reuse predefined animation. Life Forms enables you to paste motion s
one model to another. The Joint Map editor lets you control how moti
applied from the a source to a destination model.

• blend the actions of various body joints by pasting motion of selected 
from one animation to another.

A LIBRARY OF MOTIONS

SMART PASTE FUNCTIONS
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Life Forms takes the guess work out of motion editing by providing easy
ways for you to make adjustments to your animation. This is why Life Fo
ing used for projects which have large animation component. Game char
tion and crowd scenes are just a few examples. 

• Editing a Range of frames: The Range edit feature enables you to app
absolute rotation to one or more joints over a range of frames. For exam
sequence that is perfect for your needs except that the head should be 
instead of forward. In Life Forms, this is simple matter to fix. Simply se
and apply an absolute or relative rotation to the head so that it faces th
tion.

• Editing the Path: Life Forms has simple and effective controls for rota
lating a path.

• Adjusting the timing: You can quickly change the duration of the anim
expanding or compressing a range of frames. 

MOTION EDITOR
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